Oz Isuzu Forums

General Boards => Off Topic => Topic started by: paul waldo on Jul 24, 2018, 01:16:15 PM

Title: transmission oil eco graphics
Post by: paul waldo on Jul 24, 2018, 01:16:15 PM
i have an up dated  mux 4x2  done 20k i have done very little towing with box trailer about 50 kilos load 12 times about 10 kilometers and the oil in my transmission is black .is this normal .?my tyres are scrubbing out
and the rear main seal is leaking has anyone else had any of these problems. the eco graphics has never worked i am told by isuzu it can take up to 2 years to read .i have never had any thing in a car that takes 2 years to work.I want my old cruiser back.   
Title: Re: transmission oil eco graphics
Post by: sdouglas on Jul 24, 2018, 04:40:52 PM
Sounds like you need to give that dealer a miss. Towing that sort of load the MUX won't even have noticed it was there. Rear main seal shouldn't be leaking so best you start on the warranty rollercoaster. Two years to have the ECO graphics work, that's a long gestation period.
Title: Re: transmission oil eco graphics
Post by: Bob on Jul 24, 2018, 05:13:07 PM
I thought the transmission fluid was black anyway?
Title: Re: transmission oil eco graphics
Post by: DannyG on Jul 25, 2018, 11:07:45 AM
i have an up dated  mux 4x2  done 20k i have done very little towing with box trailer about 50 kilos load 12 times about 10 kilometers and the oil in my transmission is black .is this normal .?my tyres are scrubbing out
and the rear main seal is leaking has anyone else had any of these problems. the eco graphics has never worked i am told by isuzu it can take up to 2 years to read .i have never had any thing in a car that takes 2 years to work.I want my old cruiser back.

I think the transmission fluid is pretty dark? Was there a reason you were changing it at 20,000 Kays?

Sounds like you need a wheel alignment. Pretty common on new vehicles sadly.

Leaking rear main seal was an issue on some of the earlier Isuzu's, it was very isolated, but yes Id be straight back to the dealer for warranty on that one.

Yes the ECO graphics take a while to grow tree's if thats what you mean? I havent looked at mine since the day I picked the vehicle up, does anyone?  :laughing7:

The early 200 series Cruisers took 2 years to 'bed in' the rings didnt they? Or at least thats what the dealers were saying to justify the oil consumption  :evil6: